Legacy Sfax Driver Certificate Warning

As of February 2016, the Sfax Print Driver has been replaced with a newer version!

If you are sending faxes from your desktop Windows system, and you're using the legacy version of the Sfax Print Driver (shown with a blue shield logo), you will begin to receive notifications that the Security Certificate has expired. We no longer support this version of the Sfax Print Driver and you will need to please upgrade to the newest driver version to continue use.

To install the latest version of the Sfax Print Driver, please view this article: Sfax for Windows 2.0: How to Install, Uninstall or Update

If you continue to experience issues after completing the upgrade to the latest release, please submit a ticket to our Support team for assistance by emailing sfax.help@scrypt.com